トップ «前の日記(2020-11-14 (Sat)) 最新 編集   RSS 1.0 FEED  

Journal InTime


2020-12-25 (Fri) [長年日記]

_ Ruby 3.0.0へのアップグレード

Ruby 3.0.0がリリースされたので日記をアップグレードした。

最初以下のエラーで起動しなかったがGemfileにwebrickを追加したら解決した。

/home/shugo/app/jit/vendor/bundle/ruby/3.0.0/gems/tdiary-5.1.4/lib/tdiary/rack/auth/basic.rb:2:in `require': cannot load such file -- webrick/httpauth/htpasswd (LoadError)

mongodbがRuby 3.0.0に対応していないようなのでMatzにっきはしばらく様子見。

Tags: Ruby tDiary